Возможные ошибки
1. Ошибка 1. Не запускается ВМ HostedEngine
После обновления и перезагрузки хоста с ролью HostedEngine, который является единственным с этой ролью, может не запуститься ВМ HostedEngine:
hosted-engine --vm-status
The hosted engine configuration has not been retrieved from shared storage yet,
please ensure that ovirt-ha-agent service is running.
В этом случае следует перезапустить сервис ovirt-ha-agent:
systemctl restart ovirt-ha-agent
и через некоторое время проверить состояние ВМ:
hosted-engine --vm-status
--== Host znode1.local.ru (id: 1) status ==--
Host ID : 1
Host timestamp : 608
Score : 3400
Engine status : {"vm": "up", "health": "good", "detail": "Up"}
2. Ошибка 2. Не доступны центры данных в управляемых сетях
При переходе в раздел выдает ошибку и не отображает Дата центры при создании логической сети.
В этом случае вам будет необходимо перезагрузить службы:
systemctl restart zvirt-engine-backend
systemctl restart ovirt-engine
3. Ошибка 3. Ошибка Running QEMU processes found
Обновление хоста завершается следующей ошибкой:
Error: Running QEMU processes found, cannot upgrade Vdsm
Эта ошибка указывает на то, что на обновляемом хосте есть включенные ВМ.
Для устранения ошибки выключите или мигрируйте все ВМ с обновляемого хоста и перезапустите процесс обновления.
4. Ошибка 4. В лог-файле появляется ошибка Failed to fetch node_exporter
После обновления в лог-файле /var/log/ovirt-engine/engine.log появляется ошибка Failed to fetch node_exporter.
Для устранения ошибки запустите службу systemctl:
systemctl enable --now node_exporter
5. Ошибка 5. Ошибка failed to link /usr/sbin/ovs-vswitchd → /etc/alternatives/ovs-vswitchd
По завершении обновления в версии 1.1 до версии 1.2 возникает ошибка failed to link /usr/sbin/ovs-vswitchd → /etc/alternatives/ovs-vswitchd.
Причиной возникновения является конфликт при создании симлинка /usr/sbin/ovs-vswitchd → /etc/alternatives/ovs-vswitchd во время удаления openvswitch-dpdk-1:3.1.1-2.el7.
Ошибку можно игнорировать, т.к. OVS/OVN работают через PATH.