Для улучшения работы сайта мы используем файлы cookies. Оставаясь на сайте, вы соглашаетесь с политикой обработки персональных данных.

Возможные ошибки

1. Ошибка 1. Ошибка "Error, could not touch target" при восстановлении Менеджера управления из резервной копии

Процесс восстановления Менеджера управления из резервной копии в новый домен завершается ошибкой:

Error, could not touch target: [Errno 2] No such file or directory: b'/etc/yum/pluginconf.d/versionlock.list'", "path": "/etc/yum/pluginconf.d/versionlock.list", "warnings": ["Platform linux on host localhost is using the discovered Python interpreter at /usr/bin/python3.8, but future installation of another Python interpreter could change the meaning of that path. See https://docs.ansible.com/ansible-core/2.13/reference_appendices/interpreter_discovery.html for more information."]

Эта ошибка указывает на отсутствие на хосте пакета исправления fix-versionlock-symlink.

Для устранения ошибки:

  1. Установите пакет исправления, выполнив команду:

    dnf install fix-versionlock-symlink
    Если после выполнения команды возникает ошибка, связанная с отсутствием данного пакета исправлений, скачайте образ extras из репозитория или обратитесь в службу технической поддержки.
  2. Повторите попытку восстановления Менеджера управления.

2. Ошибка 2. Ошибка "There was some problem with the storage domain" при восстановлении Менеджера управления из резервной копии

Процесс восстановления Менеджера управления из резервной копии в новый домен завершается ошибкой:

There was some problem with the storage domain, please try again

Для устранения ошибки:

  1. Установите пакет исправления, выполнив команду:

    dnf install ansible-hosted-engine-fixes
    Если после выполнения команды возникает ошибка, связанная с отсутствием данного пакета исправлений, скачайте образ extras из репозитория или обратитесь в техническую поддержку.
  2. Повторите попытку восстановления Менеджера управления.

3. Ошибка 3. Ошибка "Existing database 'engine' or user 'engine' found and temporary ones created" при восстановлении Менеджера управления из резервной копии с перезаписью существующей конфигурации

Существует база данных или роль Engine.

Причиной появления ошибки является наличие баз данных, ролей или временных объектов после очистки. Попытка повторного восстановления завершится с этой же ошибкой.

Для устранения ошибки:

  1. Выведите список баз данных и ролей, выполнив команды:

    \l
    \du
  2. Удалите полученные записи.

  3. Повторите попытку восстановления Менеджера управления.

Для получения более подробной информации об удалении баз данных и ролей обратитесь в службу технической поддержки.

4. Ошибка 4. Ошибка "ltree syntax error" при восстановлении Менеджера управления из резервной копии с перезаписью существующей конфигурации

Процесс восстановления Менеджера управления из резервной копии с перезаписью существующей конфигурации завершается ошибкой:

ltree syntax error

Для устранения ошибки:

  1. Установите пакет исправления на временной виртуальной машине Hosted Engine, выполнив команду:

    dnf install ltree-fix
    Если после выполнения команды возникает ошибка, связанная с отсутствием данного пакета исправлений, скачайте образ extras из репозитория или обратитесь в службу технической поддержки.
  2. Повторите попытку восстановления Менеджера управления.