Для улучшения работы сайта мы используем файлы cookies. Оставаясь на сайте, вы соглашаетесь с политикой обработки персональных данных.

Не запускается синхронизация LDAP, если предыдущая не была завершена корректно

Для версии 2.3
Проблема

При прерывании связи между брокером и LDAP каталогом (выключение сервера, потеря сетевого соединения) во время выполнения синхронизации происходит её зависание и повторная синхронизация не запускается.

Причина

Прерванная синхронизация LDAP считается запущенной.

Решение

Для запуска новой синхронизации LDAP необходимо сбросить в базе данных текущую синхронизацию. Для этого:

  1. Подключитесь к базе данных.

  2. Найдите запущенную синхронизацию с помощью команды:

    select * from ldap_sync_result;
  3. Выберите id записи, у которой не указана дата окончания синхронизации.

  4. Удалите запись об активной синхронизации с помощью команды:

    delete from ldap_sync_result where id='a2b7b66c-548d-42ec-9d04-0da876d81c18';
  5. Запустите синхронизацию из меню Termit повторно.