История изменений
История изменений отражает хронологию развития платформы Nova Container Platform: расширение функциональности, изменения, исправления ошибок и другие обновления.
v7.6.2
Август 2026
Расширение функционала
-
Добавлен оператор ArgoCD v0.18.0 в OperatorHub, включающий в себя ArgoCD v3.3.10.
Подробнее см. в разделе Argo CD.
Улучшения
-
Добавлена поддержка S3-совместимых хранилищ и приватных TLS-сертификатов.
В
defaultBackupLocationVelero добавлены три параметра для хранилищ, отличных от AWS S3 (MinIO, Ceph и др.):config.s3ForcePathStyle,config.insecureSkipTLSVerify,objectStorage.caCert.Подробнее см. в статье Защита пользовательских данных с помощью модуля Data Protection.
-
Внесены изменения в Cluster Manager:
-
Реализована интеграция с провайдерами zVirt, K2Cloud и vSphere, позволяющая автоматически получать данные о шаблонах, кластерах, сетях и других сущностях через API провайдера. Ручной ввод идентификаторов и названий заменён на выбор значений из выпадающих списков.
Разделы Настройки провайдеров и Хост-группы удалены, форма учётных данных для доступа к API изменена, прежние учётные данные не сохраняются. При обновлении Nova Universe раннее созданные учётные данные удалятся и потребуют повторного создания.
-
Добавлена возможность скачивания сертификатов кластера на вкладке Конфигурация.
-
Добавлена возможность удаления задач.
-
Скрыты токены расшифровки хранилища StarVault на вкладке Конфигурация.
-
Для хост-групп провайдера zVirt реализовано автоматическое заполнение полей Сокетов ЦП, Ядер ЦП и Потоков на ядро в зависимости от значения поля ЦП и автоматическая коррекция значений полей Макс. ОЗУ и Фикс. ОЗУ.
-
Для хост-групп провайдера vSphere реализовано автоматическое заполнение поля Ядер на сокет в зависимости от значения поля ЦП.
-
В хост-группах провайдера K2Cloud добавлен параметр Метаданные.
-
Во вкладке Задачи кнопки скачивания журнала и манифеста объединены в одну с возможностью скачать все файлы разом.
-
Улучшена работа пагинации, сортировки и поиска в веб-интерфейсе.
-
Исправление ошибок
-
Исправлена проблема истечения срока действия токена при выполнении запросов на вкладке Дашборд плагина Мониторинг в консоли Nova.
-
Исправлена ошибка, из-за которой OperatorHub создавал лишние сетевые политики при добавлении каталога операторов.
-
Исправлена ошибка, из-за которой невозможно было сохранить настройку NodeVolumeConfig после удаления узла в консоли Nova.
-
Исправлена ошибка, из-за которой операция масштабирования мастер-узлов могла завершиться с ошибкой зависания kube-proxy.
-
Исправлена ошибка в Prometheus, из-за которой в HA-кластере из трёх конечных точек target’а nova-oauth отображалась только одна конечная точка.
-
Убрана проверка соответствия версии после обновления Universe через API.
-
Исправлены ошибки Cluster Manager:
-
Исправлена ошибка вёрстки, из-за которой таблицы в разделах не растягивались на всю ширину.
-
Исправлена ошибка, из-за которой при повторе задачи на создание кластера в форме не отображалась версия Kubernetes.
-
Исправлена ошибка, из-за которой новая строка для ввода данных не добавлялась к уже существующей пустой строке.
-
Исправлена ошибка создания кластера с пользовательским СА-сертификатом.
-
Информационная безопасность
-
Выпущено обновление безопасности.
Данное обновление включает следующий бюллетень безопасности:
-
ORION-NOVA-2026-08-19-01
Обновление исключает риски эксплуатации следующей уязвимости в компонентах Nova:
-
CVE-2016-2183
-
v7.6.1
Описание обновления
Июль 2026
Расширение функционала
-
Добавлена поддержка ОС для сервера управления Nova Universe v3.1.4.
-
Alt Linux 10.2.2
-
MosOS 15.5
Подробнее см. в разделе Матрицы совместимости.
-
-
Добавлена поддержка совместной работы multipathd и Longhorn.
В черный список multipathd добавлены правила для блокировки устройств по IET / VIRTUAL-DISK. Это снимает ранее существовавшее ограничение и позволяет запускать multipathd на всех узлах параллельно с томами Longhorn. Это позволяет использовать multipathd для других сценариев без ущерба для работы платформы.
-
Добавлено поле customPatches в операторы компонента OperatorHub, которое позволяет сохранять пользовательские изменения (патчи).
Пользовательские изменения (патчи) теперь привязываются к кастомизации через customizationName.
Подробнее см. в статье Управление дополнительной конфигурацией приложения
-
Прекращена поддержка Astra Linux Special Edition 1.7.5.
Улучшения
-
Добавлена возможность принудительного удаления поврежденных узлов из кластера, включая мастер-узлы, а также механизмы их восстановления.
Подробнее см. в статье Восстановление неработоспособных узлов
-
Добавлен мониторинг срока действия системных сертификатов платформы.
-
Добавлено автоматическое обновление сертификатов при обновлении версии платформы.
-
Добавлен дашборд Kubernetes Deprecated API в Grafana для контроля использования устаревших Kubernetes API.
-
Добавлено автоматическое заполнение минимальной рабочей конфигурации приложения при первом создании ресурса в OperatorHub, включая поле
metadata.name. -
Добавлена утилита Cosign в состав Universe для подписи и проверки цифровых подписей контейнерных образов и других артефактов.
-
Добавлена очистка узлов от компонентов Nova в режиме IPI, если был выбран вариант не удалять виртуальные машины.
-
Удалены устаревшие панели из дашборда Cilium-Agent BPF.
-
Внесены изменения в Cluster Manager:
-
Добавлено отображение текущей версии Nova Universe в интерфейсе Cluster Manager.
-
Добавлено отображение статусов узлов и системных приложений в списке кластеров.
-
Добавлено отображение версии K8s у ранее добавленных кластеров, а также при выборе версии в форме создания кластера.
-
-
Внесены изменения в Cilium CNI:
-
Оптимизирована конфигурация Cilium, что повышает стабильность работы платформы на физических серверах с большим объемом ресурсов.
-
Включен Host Firewall по умолчанию для новых кластеров.
-
Исправление ошибок
-
Исправлен сбор метрик мониторинга StarVault.
-
Исправлен сбор логов containerd в OpenSearch.
-
Исправлена ошибка работы Cilium на физических серверах с большим количеством процессорных ядер и оперативной памяти.
-
Исправлена ошибка некорректного изменения dnsPolicy после миграции на Universe v3.
-
Исправлена проблема в Node Local Gateway, которая могла приводить к некорректной работе L7-политик Cilium.
-
Исправлена проблема установки платформы методом IPI в среде VMware на ОС Ubuntu.
-
Исправлена потеря пользовательских патчей (customPatches) при миграции операторов через OperatorHub.
-
Исправлено автоматическое заполнение конфигурации приложения при первоначальном создании ресурса в OperatorHub.
-
Исправлена ошибка, из-за которой сервис мог стать недоступным при настройке подключения к базе данных.
-
Исправлены ошибки Cluster Manager:
-
Ошибка, из-за которой в задачах на удаление кластера счетчик этапов отображался некорректно.
-
Ошибка, приводившая к сбою веб-интерфейса при попытке вывести из управления кластер без назначенного имени.
-
Некорректное поведение формы добавления DNS-серверов при вводе дублирующего значения.
-
Ошибка обновления токенов StarVault при масштабировании узлов с ролью Мастер.
-
-
Исправлены ошибки Nova Console:
-
Ошибка создания NetworkPolicy.
-
Некорректная работа поиска по меткам (labels) в пространстве имен (Namespaces).
-
Обновление компонентов
-
Обновлен NeuVector до версии 5.5.0.
-
Обновлен ingress-controller до версии v1.14.5-nova.r2.
-
Обновлен nova/backup-daemon до версии v1.1.2.
-
Обновлена Nova Console до версии v1.0.8.
-
Обновлен Cilium CNI до версии 1.16.19-nova.r2.
Информационная безопасность
-
Выпущено обновление безопасности.
Данное обновление включает следующий бюллетень безопасности:
-
ORION-NOVA-2026-07-15-01
Обновление исключает риски эксплуатации следующей уязвимости в компонентах Nova:
-
CVE-2026-42945
Для получения подробной информации о бюллетенях безопасности, используйте поиск на странице Бюллетени безопасности в разделе Безопасность.
-
Для просмотра списка всех обновлений перейдите к соответствующему разделу базы знаний Релизы и обновления.
v7.6.0
Описание обновления
Май 2026
Расширение функционала
-
Добавлена поддержка ОС для сервера управления Nova Universe v3.1.3:
-
AstraLinux 1.7.9
-
AstraLinux 1.8.3
Подробнее см. в разделе Матрицы совместимости.
-
-
Добавлен OperatorHUB – централизованный каталог платформенных модулей.
OperatorHUB позволяет устанавливать и управлять дополнительными сервисами платформы без ручного взаимодействия с Helm и Flux-манифестами. В каталог включены следующие модули:
-
Neuvector
-
Service Mesh
-
OpenSearch
-
Data Protection
-
Storage
-
Kyverno
-
Metallb
-
ML Platform
-
Ml Infra
Подробнее см. в разделе OperatorHUB.
-
-
Добавлена поддержка горизонтального масштабирования мастер-узлов кластера Kubernetes.
Улучшения
-
Добавлены изменения для соответствия обновленным стандартам безопасности CIS Kubernetes Benchmark V1.12.0.
-
Добавлены изменения в интерфейсе Nova Console:
-
Поддержка установки StorageClass по умолчанию
-
Поддержка мультивыбора с возможностью удаления выбранных ресурсов одним кликом
-
Поддержка пагинации
-
-
Перенесен Ingress-ресурс StarVault (nova-oauth) в пространство имен kube-system. Добавлена поддержка динамической балансировки трафика из Kubernetes в StarVault.
-
Обновлена спецификация NodeVolumeConfig в API-группе
storage.nova-platform.ioдо версии v1alpha2.
Исправление ошибок
-
Исправлена ошибка, из-за которой веб-интерфейс Cilium Hubble не запускался на узлах с выключенным IPv6.
-
Исправлена ошибка
failed to unmount deviceпри удалении Volume из NodeVolumeConfig. -
Исправлена ошибка в nova-backup-daemon в логике определения количества узлов в кластере для параметров задания резервного копирования (
parallelism,completions). -
Исправлена ошибка, из-за которой при удалении модуля Longhorn в кластере оставались ресурсы
backuptarget, которые блокировали полное удаление модуля. -
Внесены исправления в интерфейсе Nova Console:
-
Исправлена ошибка создания правил приостановки оповещений.
-
Исправлено некорректное отображение дополнительной информации о предупреждениях.
-
Исправлено некорректное отображение раздела управления модулем резервного копирования после его отключения.
-
Исправлена ошибка бесконечной загрузки логов заданий резервного копирования.
-
Исправлена ошибка CiliumNetworkPolicy, из-за которой правило блокирования входящего и исходящего трафика создавалось некорректно.
-
Обновление компонентов
-
Обновлен x509-certificate-exporter до версии 3.20.1.
-
Обновлен ingress-controller до версии 1.14.5.
-
Обновлен cilium до версии 1.16.19.
-
Обновлен Longhorn до версии 1.9.2.
Информационная безопасность
-
Обновление безопасности.
Данное обновление включает следующий бюллетень безопасности:
-
ORION-NOVA-2026-05-07-01
Обновление исключает риски эксплуатации следующих уязвимостей и ошибок в компонентах Nova:
-
CVE-2026-3288
-
CVE-2026-4342
Для получения подробной информации о бюллетенях безопасности, используйте поиск на странице Бюллетени безопасности в разделе Безопасность.
-
v7.5.0
Описание обновления
Март 2026
Расширение функционала
-
Добавлена поддержка ОС для сервера управления Nova Universe v3.1.2:
-
Alt Linux 11.0
-
Ubuntu 24.04
-
AlmaLinux 9.7
Подробнее см. в разделе Матрицы совместимости.
-
-
Добавлена поддержка Ubuntu 24.04 в Nova AI.
Подробнее см. в документации Инструкция по установке GPU драйверов.
-
Обновлена дизайн-система веб-консоли Nova Container Platform.
Подробнее см. в документации Обзор консоли.
Улучшения
-
Добавлены возможности для ресурса MLCluster в части компонента JupyterHub в Nova AI:
-
Использовать GPU ресурсы
-
Настраивать TTL (время жизни) подов Jupyter Notebook
Подробнее см. в документации Nova AI. Установка.
-
-
Добавлена расширенная настройка сетевых интерфейсов на этапе установки для кластеров, разворачиваемых методом IPI (bare metal).
Спецификация Infrastructure в API-группе config.nova-platform.io обновлена до версии v1alpha7.
Подробнее см. в документации v1alpha7.
-
Добавлена поддержка сканирования на уязвимости узлов с ОС Alt Linux в сканер Neuvector.
-
Скорректировано количество реплик Grafana в модуле Service Mesh до 1.
Подробнее см. в документации Nova Service Mesh. Установка модуля.
-
Улучшена стабильность SSH-подключения к узлам кластера в nova-ctl.
-
Добавлена поддержка конфигурации тегов для узлов Host Group при установке платформы в К2Cloud методом IPI.
Подробнее см. в документации v1alpha7.
-
Добавлена поддержка включения новых доменов в PKI-политики StarVault при масштабировании узлов кластера Kubernetes.
Исправления ошибок
-
Исправлена ошибка, которая приводила к невозможности входа в Grafana через SSO.
-
Исправлена ошибка, из-за которой обновление платформы завершалось сбоем при использовании пользовательской цепочки TLS-сертификатов (caTrustBundle).
-
Исправлена ошибка, из-за которой в Airflow не удавалось создавать переменные.
-
Исправлена ошибка, из-за которой при миграции кластера Nova на Universe v3 для kube-proxy применялась некорректная конфигурация.
-
Исправлена ошибка, из-за которой не работал мониторинг кластера Ray.
-
Исправлена проблема, из-за которой токен StarVault мог оставаться в логе nova-ctl после неуспешного обновления платформы.
-
Исправлено отображение статуса в ресурсах, устанавливаемых Apps Operator в интерфейсе.
-
Исправлена проблема, из-за которой после установки модуля Longhorn в кластере могло возникать множество событий PodDisruptionBudgetAtLimit.
Обновление компонентов
-
Обновлен Longhorn до версии v1.8.2.
-
Обновлен containerd до версии v1.7.25-4.
-
Обновлен Nova Universe до версии v3.1.2.
Подробнее см. в документации Nova Universe.
-
Обновлен ingress nginx controller до версии v1.14.1.
v7.4.0
Описание обновления
Декабрь 2025
|
Перед обновлением кластера Nova до версии 6.5.0 или 7.4.0 проверьте готовность компонента Longhorn, если он у вас установлен. С условиями ознакомьтесь в пререквизитах инструкции по обновлению платформы. |
|
Обращаем ваше внимание, что для онлайн‑установки кластера был изменен перечень IP‑адресов сервисов. Актуальный список доступен по ссылке. |
Расширение функционала
-
Добавлена поддержка Ubuntu 24.04. LTS.
Установка доступна во всех режимах, кроме IPI-режима в среде K2Cloud.
-
Доработан интерфейс раздела управления резервным копированием в Nova Console. Добавлены две возможности:
-
Приостанавливать и возобновлять расписания
-
Создавать и настраивать BackupStorageLocation
Подробнее см. в документации Резервное копирование узлов.
-
-
Добавлены формы создания ресурсов для управления хранилищем Longhorn в Nova Console. Добавлены следующие формы:
-
LonghornClusterConfig — для настройки параметров кластера и хранилища Longhorn
-
NodeVolumeConfig — для управления конфигурациями томов узлов
Подробнее см. в документации Примеры использования.
-
-
Добавлена новая редакция сервера управления Nova Universe v3.1.0 в Tech Preview.
В состав входит Cluster Manager — веб-интерфейс для централизованного управления несколькими кластерами Nova Container Platform в изолированных средах без доступа к интернету.
Подробнее см. в документации Cluster Manager.
Улучшения
-
Улучшена проверка пересечения доменных зон в nova-ctl для установки платформы и Nova Universe.
-
Добавлено сохранение лога nova-ctl по умолчанию для всех выполняемых операций с кластером. Лог сохраняется в том числе при прерывании операции пользователем.
-
Добавлена поддержка дополнительной конфигурации CRL и OCSP URL для всех PKI в Starvault.
-
Расширено логирование событий в nova-ctl для всех типов операций с кластером.**
Для каждого узла кластера добавлена следующая информация:
-
Версия платформы
-
Конфигурация установки
-
ОС и ядро
-
Сетевые параметры
-
Утилизация ресурсов
-
Настройки прокси
-
-
Добавлена поддержка автодополнения для всех команд в nova-ctl.
Исправления ошибок
-
Исправлена проблема, при которой могла возникать ошибка во время установки драйверов GPU на ОС РЕД ОС 8.0.
-
Исправлена проблема, при которой на узлах с ОС Astra Linux возникала проблема с доступом к публичному сервису настройки ПО через прокси.
-
Исправлена проблема, при которой проверка установленных системных приложений в nova-ctl могла выполняться бесконечно и не завершаться.
-
Исправлена ошибка недоступности UI MinIO. Ошибка возникала при использовании пользовательских сертификатов для ingress платформы в конфиге ingressTLSConfig.
-
Исправлена проблема, при которой узел кластера мог быть пересоздан при вертикальном масштабировании (увеличения CPU, Memory).
-
Исправлена проблема, при которой токен Starvault мог оставаться в логе nova-ctl после неуспешного обновления платформы.
-
Исправлена проблема некорректной работы настроек прокси в ОС Astra Linux.
-
Исправлена проблема, при которой операция Drain узла не выполнялась из веб-консоли Nova. Ошибка возникала, если кластер установлен в закрытом сетевом окружении.
-
Исправлена проблема с добавлением нового ingress-узла в кластер. Из-за этой проблемы добавление нового ingress-узла в кластер могло завершаться ошибкой:
Command 'sudo kill -9 210090 210091 210856' exited with code 64 -
Исправлена проблема с длительным завершением работы веб-консоли Nova.
Обновление компонентов
-
Обновлен Longhorn до версии v1.7.3.
-
Обновлен Nova Universe v2 до версии v2.1.18.
Известные проблемы и ограничения
Проблема/Ограничение |
Описание |
Возможное решение |
Отключение службы multipathd |
Отключена служба multipathd на всех узлах платформы в версиях Nova 6.5.0 и 7.4.0 для устранения конфликта между multipathd и системой хранения Longhorn. |
Если в вашей инфраструктуре multipathd используется для сценариев, не связанных с платформой и Longhorn, пожалуйста, сообщите об этом в техническую поддержку перед обновлением. |
v7.3.0
Описание обновления
Ноябрь 2025
|
При обновлении платформы до версий 6.4.0 или 7.3.0, если ранее установка выполнялась методом IPI на zVirt или vSphere, использование nova-ctl scale может приводить к пересозданию узлов кластера. Такое поведение будет исправлено в ближайшем патч-релизе. |
Расширение функционала
-
Добавлено решение для организации полного жизненного цикла машинного обучения (ML) Nova AI, включающее в себя разработку, обучение, развертывание и сопровождение моделей. Решение построено на базе Kubernetes и интегрирует в себя современные open-source компоненты, а также инструменты NVIDIA для работы с GPU и высокопроизводительными сетями (см. документацию Nova AI).
-
Добавлена поддержка Taint node.longhorn.io/member:NoSchedule в кластере Longhorn. Это позволяет администраторам запрещать размещение пользовательских Pod на узлах, входящих в кластер Longhorn, тем самым выделяя такие узлы исключительно для работы компонентов Longhorn и предотвращая запуск на них других нагрузок.
-
Добавлена новая конфигурация cloud-init для автоматического определения и настройки активного сетевого интерфейса на поддерживаемых ОС в zVirt и VMware.
-
Добавлена в Node Config Operator поддержка управления конфигурацией прокси-сервера, заданного при инициализации платформы.
-
Добавлена поддержка указания диапазона портов в Nova Console (новое поле - endPort) в правилах ingress CiliumNetworkPolicy.
Улучшения
-
Добавлена автоматическая валидация конфигурации Cilium перед обновлением.
-
Добавлена проверка файловой системы при IPI-установке кластера в nova-ctl. При нестандартной разметке дисков выводится предупреждение.
-
Добавлена кликабельная ссылка на URL ресурса в Nova Console в разделе Ingress
Исправления ошибок
-
Исправлены следующие ошибки в Nova Console:
-
Исправлено округление значений утилизации CPU и некорректные переводы состояний Pod-в.
-
Исправлена проблема, при которой нельзя было выбрать селектор меток во время создания ресурсов Backup или Restore.
-
-
Исправлена ошибка некорректного применения конфигурации Registry через NodeConfig при использовании authConfig.
-
Исправлена ошибка, из-за которой в веб-интерфейсе резервного копирования нельзя было добавить дополнительный селектор меток при создании или восстановлении бэкапа.
-
Исправлена ошибка, из-за которой при установке кластера на ALSE 1.8.1 методом IPI не срабатывала валидация файловой системы, что приводило к сбою установки из-за нехватки места.
Обновление компонентов
-
Обновлен Cilium CNI до версии 1.16.12.
-
Nova Console обновлена до версии 0.4.12
|
Установка в IPI-режиме в VMware на текущий момент не поддерживается и находится в процессе тестирования |
v7.2.0
Описание обновления
Октябрь 2025
Улучшения
-
Добавлена поддержка ОС AlmaLinux 9.6.
-
Добавлена поддержка динамического получения списка дисков из шаблона при IPI-развертывании в vSphere. nova-ctl формирует root-диск по параметрам манифеста, а остальные диски наследует из шаблона без последующего управления.
Исправление ошибок
-
Исправлена проблема, из-за которой резервное копирование worker-узлов завершалось с ошибкой в кластере с минимальной конфигурацией
-
В интерфейсе Nova Console исправлен баг отображения BackupStorageLocation, когда у ресурса отсутствовал параметр Phase или Credentials.
v7.1.0
Описание обновления
Сентябрь 2025
|
При обновлении платформы до версий 6.2.0 или 7.1.0, если ранее выполнялась настройка аутентификации с использованием LDAP или других методов, пользовательские настройки Application (блок OIDC Provider) в StarVault перетираются. После обновления - заново добавьте созданные вами Assignments в Applications. |
|
При обновлении до версий 7.1.0, 6.2.0 и 5.2.5 изменения в манифестах kustomization 'nova-release-ingress-public-main' и 'nova-release-ingress-internal-main' будут сброшены к стандартной конфигурации. Если в эти манифесты вносились изменения, рекомендуется сохранить их перед обновлением, чтобы затем восстановить вручную. |
Расширение функционала
-
Добавлен модуль Service Mesh на базе Istio с поддержкой Gateway API и интеграцией платформенных сервисов (см. документацию Nova Service Mesh).
-
Добавлена поддержка инфраструктурного провайдера K2Cloud (см. документацию Интеграция с K2Cloud).
-
Добавлен Node Local Gateway - локальный балансировщик трафика на каждом узле кластера, за счет которого все Ingress-контроллеры вынесены из хостового сетевого пространства (HostNetwork) и улучшена работа сетевых политик с пограничным трафиком.
Улучшения
-
Все компоненты платформы переведены на работу с Kubernetes API через Node Local Gateway для повышения доступности. Для ознакомления перейдите к документации Node Local Gateway.
-
Веб-консоль Nova обновлена до версии 0.4.11. Повышена стабильность и исправлены ошибки в работе плагинов мониторинга и резервного копирования.
-
Добавлена возможность выполнять операцию вывода узла кластера в режим обслуживания (drain node) через web-интерфейс nova-console (см. документацию Перевод узла кластера в режим обслуживания)
-
Обновлены компоненты FluxCD:
-
reflector-controller - v0.35.2
-
automation-controller - v0.41.2
-
source-controller - v1.6.2
-
kustomize-controller - v1.6.1
-
-
Агент резервного копирования nova-backup-daemon обновлен до версии v1.1.0. Добавлена поддержка резервного копирования рабочих узлов кластера.
-
В Ingress Nginx (internal, public) добавлены по умолчанию дополнительные заголовки безопасности:
Referrer-Policy: origin-when-cross-origin X-Content-Type-Options: nosniff X-Frame-Options=sameorigin Strict-Transport-Security=max-age=31536000; includeSubDomains;Заголовок Content-Security-Policy принудительно не устанавливается и остается на усмотрение пользователя.
Управление данными заголовками осуществляется через ConfigMap:
nova-ingress-public/nova-ingress-public-custom-add-headers nova-ingress-internal/nova-ingress-internal-custom-add-headers -
Для сервисов Prometheus, Alertmanager, Thanos Query добавлены
-default-denyIngress-ресурсы. Данные ресурсы могут быть использованы для настройки точечных ограничений доступа в рамках каждого сервиса. По умолчанию настроено ограничение доступа к/debug/pprof.
Исправление ошибок
-
Исправлена ошибка обновления платформы на ОС семейства RHEL в конфигурации с несколькими ресурсами, использующими PV из Longhorn.
-
Исправлена проблема, из-за которой source-controller при работе с репозиториями Helm мог выдавать ошибку:
`{"level":"error","ts":"2025-08-08T08:41:56.197Z","logger":"runtime","msg":"Observed a panic: \"invalid memory address or nil pointer dereference\" (runtime error: invalid memory address or nil pointer dereference)` -
Исправлена проблема, при которой вход в платформенные веб-интерфейсы, защищенные oauth2 proxy, был невозможен используя учетную запись метода аутентификации LDAP (Ошибка 500).
-
Исправлена проблема, при которой в Grafana могли не появляться отдельные дашборды с состоянием кластера Kubernetes.
-
Исправлена обработка значений с плавающей точкой в выводе df при вычислении свободного места, из-за которой валидация get_node_free_disk_space завершалась с ошибкой.
-
Исправлена логика проверки занятости портов, чтобы корректно выявлять конфликты с сервисом systemd-resolved и исключить сбои установки при включенном DNS-резолвере.
|
Установка на Astra Linux 1.8.1 в IPI-режиме в среде VMware на текущий момент не поддерживается и находится в процессе тестирования. |
v7.0.0
Описание обновления
Июль 2025
Вышла новая версия Nova Container Platform v7.0.0, построенная на базе Kubernetes v1.31. Теперь одновременно поддерживаются следующие версии платформы:
-
v5.x.x - на базе k8s 1.29
-
v6.x.x - на базе k8s 1.30
-
v7.x.x - на базе k8s 1.31
Обновление компонентов
Cледующие компоненты платформы обновлены до версий:
-
kubernetes - 1.31.9
-
etcd - 3.5.21
-
cri-tools - 1.31.0
-
grafana - 12.0.1
-
opensearch - 2.19.2
-
fluxcd/helm-controller - 1.3.0
-
fluxcd/image-automation-controller - 0.41.0
-
fluxcd/image-reflector-controller - 0.35.0
-
fluxcd/kustomize-controller - 1.6.0
-
fluxcd/notification-controller - 1.6.0
-
fluxcd/source-controller - 1.6.0
-
StarVault - 1.1.0
Улучшения
-
Для zVirt реализован вертикальный скейлинг без перезапуска виртуальных машин (ВМ): теперь при изменении параметров ВМ (CPU, RAM и др.) больше не происходит удаления и пересоздания машины — ресурсы изменяются на лету, без прерывания работы.
-
Отключен параметр
memory ballooningпо умолчанию при установке на zVirt. -
Вышла новая версия CRD v1alpha6, в которой добавлены новые поля:
memory_ballooningиguaranteed_memory. Подробнее можно ознакомиться с описанием параметров в Справочнике v1alpha5 -
Обновлен terraform-провайдер ovirt, в котором исправлена ошибка при назначении дополнительных параметров (custom properties) виртулальных машин в zVirt, которая возникала из-за некорректной обработки пустых значений.
-
Добавлена поддержка ОС AstraLinux 1.8.1
Установка в IPI-режиме в VMware на текущий момент не поддерживается и находится в процессе тестирования.
-
Добавлена поддержка ОС Мос.ОС
Установка поддерживается только в UPI-режиме.
-
Добавлена полноценная поддержка управления Opensearch через nova-apps-operator. Конфигурация кластеров теперь описывается через ресурс OpenSearchCluster. Также реализован механизм миграции legacy-конфигураций Opensearch в новый формат.
Конфигурация количества реплик для Opensearch теперь допускает только нечетные значения и должна совпадать с числом infra-нод. Настройки реплик для Opensearch Dashboard не изменились — могут быть любыми.
-
Добавлена возможность сбора диагностических дампов с каждого узла кластера. Сбор данных выполняется на каждом узле с помощью команды:
collect-logs. -
В рамках соответствия обновленной версии CIS Benchmark отключен Admission-плагин DenyServiceExternalIPs в kube-apiserver.
-
Теперь при наличии CNI-плагина Cilium в кластере в разделе Network Nova Console отображаются политики
CiliumClusterwideNetworkPolicyиCiliumNetworkPolicy. Это позволяет управлять сетевым доступом на уровне кластера и пространств имен с помощью Cilium-политик напрямую через интерфейс консоли. -
Валидация дискового пространства в nova-ctl дополнена проверкой разметки диска. Если обнаружены дополнительные разделы, отличные от
/,/boot*или/recovery*, то для пользователя выводится предупреждение. Это помогает избежать ошибок при установке на нестандартную разметку и предупреждает пользователя о возможных рисках в процессе установки.
Расширение функционала
-
Добавлен новый компонент — Node Config Operator (NCO), предназначенный для централизованной и декларативной настройки ОС узлов кластера через CRD Kubernetes. На данный момент NCO позволяет управлять конфигурацией Containerd без необходимости ручного вмешательства.
-
В интерфейс Nova Console добавлен динамический плагин для управления резервным копированием. Подробности о возможностях и использовании - в документации Резервное копирование и восстановление.
Исправления ошибок
-
Исправлена ошибка, из-за которой в Nova Console во вкладке Services всегда отображалась стандартная DNS-зона
cluster.local, даже если в кластере была задана другая зона через параметрk8sDefaultDnsZone. Теперь консоль корректно отображает актуальную зону, соответствующую настройкам кластера. -
Исправлена ошибка в логике podAntiAffinity в OpenSearch: при использовании HA-конфигурации все поды могли запускаться на одной infra-ноде при недостаточном количестве нод. Теперь размещение подов корректно распределяется с учетом anti-affinity правил, что повышает отказоустойчивость.
-
Исправлена ошибка запуска Cilium на узлах с установленным Kaspersky Endpoint Security (KESL). Порт
9879, используемый по умолчанию для health-проб Cilium, конфликтовал с компонентами Kaspersky. В рамках решения порт health-чеков был перенесен на25655.